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Setting up the workspace
Before you start to design any documents, it helps to set up the InDesign workspace to suit book 
design. Without starting a document, in the Window drop-down menu, under “Workspace” select 
“Book”. This should give you access to the main tools you need, and you can add panels for other tools 
as needed. Once you create a document, you will see the panels. 

If your screen is small, it can help to stack tools in groups, and open each as you need it. I always have 
the Properties panel open at the far right. This displays tools relevant to whether you are working with 
an Object (select the white arrow at the top of the tool panel at screen left), or with text (the T tool).

You can stack other tool panels up on the properties area, and access them by clicking their tab, but if 
you have the space, don’t do this, rather stack other tool panels in a new pane to the left of Properties.

Open a tool panel under the Window menu. Tools gives you the main tool strip down the left, if you 
don’t already have it. When you select any of the items under Window, a free floating pane will open, 
you can dock this panel with others at the right to give you easy access. 

Pages shows a representation of the whole document and lets you move through it. It also gives 
access to the Parent pages, and its “hamburger” menu gives access to other functions to do with the 
pages in your document (more on this later). Links is where all graphic elements in the document 
are displayed and where you can check issues like resolution etc. These are the only two of these tool 
panels you absolutely need. I group them in one pane with two tabs, because you don’t need to see 
them at the same time.

Below that, I group panels to do with image management: Swatches, which is what InDesign calls the 
panel of available colours that you can apply to lines (strokes) and shapes (fill). You can also create your 
own colours. Any you create when you have a document open only apply to that document. Also in 
this group is CC Libraries, where you can keep commonly used graphics that you can then drag into 
any document (like your bindery logo). To add an item, select it and then click the + sign at the bottom 
of the CC Libraries panel. If you no longer need it, delete by dragging to the bin logo at the bottom of 
the pane. (This is the way you add or delete items in any panel.)

The next pane is where I have grouped tools that handle shapes (Indesign calls them Objects).Find 
Object styles under Styles. This is also where paragraph styles and character styles are hidden, you will 
want to keep these open in panes as well. I also keep Text Wrap in a pane in this group: this controls 
how text wraps around an image or other shape.

It is handy to have panes you might need to use simultaneously in different groups: I have just moved 
the Character styles pane into the “Objects” group, so it can be open at the same time as Paragraph 
styles.

My final group is Paragraph styles and glyphs (which allows you to inspect all the glyphs in a font 
and select ones that might otherwise be hidden, like special characters, accented letters etc).

See pictures on the next pages of my workspace:
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Setting up a new document
When you open InDesign, the front page allows you to create a new document or open a previous one. 
The most recent documents will be displayed here and a single click will open them.

Click the “Create New” button and set the basic parameters of your document.
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You can either choose to use the parameters of a recent document (they are called Custom and the 
page dimensions if you didn’t give it a specific name), or choose a preset under “Print”.

In the panel at the right, give your new document a name and check that the page dimensions are the 
ones you want. For a book, select portrait orientation and tick “facing pages”. You only need one page 
to start. If you are importing text, leave “primary text frame” unticked. If you are going to paste text 
in, tick “primary test frames”.

Then set your margins: if they are all the same, leave the chain logo next to the margins pane alone and 
all will be the same. To set different margins, click the chain logo to unlink the margins so you can give 
each a different value. Once you are happy with the set-up, click create. You can edit the document 
set-up later if you need to.

Setting text styles
Before you import text, take a moment to write at least the basic paragraph styles you need. In the 
paragraph styles pane, with “basic paragraph” selected, in the hamburger menu,  choose “Create new 
style”.

This opens the set-up tool.
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In the General pane, name your style and choose a keyboard shortcut — make sure Num Lock is 
selected and use the control key and number pad numbers to set up shortcuts: these make styling text 
far quicker. I always use the same shortcut keys for each style, even though I write each fresh for each 
new book — in this way, muscle memory does half the work.

In this pane, everything about the style is displayed, but you have to go through the panels listed at left 
to set each of these parameters.

Paragraph styles can be based upon other styles, so it is well worth your while to set them up in a logical 
order, so that if you later want to change, say, the text font, you only need to change it in the base style, 
which will alter it in all the child styles. I start with Normal, the style for all body text (you can call it 
whatever you want, of course).

In the Basic character formats pane, set the font and the font style (regular, italic etc) and the size and 
line spacing. If you want to do tricky things like alter the width of the font etc, do this in Advanced 
character formats but in general, leave the advanced parameters alone.

Next, in the Indents and spacing menu, set the justification (left justified for normal book text) and 
the spacing: set the first line indent, and tick align all lines to baseline, this ensures that all lines of text 
line up across all pages, and is a major contributor to text looking neat. To make this work, in the Edit 
> Preferences menu, set the baseline grid spacing under Grids. Set your basic text spacing the same 
as the spacing of the baseline grid. You can make the baseline grid visible under Grids and guides in 
the View menu, but even if it is not visible, lines will align to it if the spacing and the grid are the same. 
Altering the line spacing is a way to make text take up more or less space. I personally think wider 
spacing than assigned with the Auto spacing function makes text more readable. I commonly use 10pt 
spaced on a 15pt baseline. (The current text is 12pt on a 15pt baseline.)

Set hyphenation: at 10pt on an A5 page, I turn hyphenation off. On smaller pages or at bigger text 
sizes, turning it on may give you text that is more pleasingly spaced. You can set parameters for how 
text will be hyphenated in this panel.

To avoid widows and orphans, under the Keep options menu, set keep last two lines in paragraph 
together. For other paragraph styles, you can set the Keep to Keep with next 1 or 2 lines, this is useful 
with you have sub-heads, so they don’t get stranded apart from the text they introduce.

These are the only parameters I set for Normal text. Next I set Normal no indent (the only thing that 
changes is to set the first line indent to 0) and Normal no indent space before (base this on normal no 
indent): set the space before the paragraph to the same size as one baseline.

Next, set the style for the opening line of a chapter. Base it on Normal no indent and go down to Drop 
caps and nested styles. Choose how many lines the drop cap will occupy and create a style for the drop 
cap itself. If you want to have caps or small caps for the first line, or a set number of words, set these 
in the line style and nested style areas. These styles use Character styles: anytime a style applies to a 
word or letter within a paragraph, you should control that with a character style. The basic one you 
will need is an italic style. It is better to use character styles than to just adjust the style of text on the fly.

Next, I set the chapter title style: this is another “parent style” that I will base all the elements that use 
the title font on, thus, if I change my mind about the title font, I only need to alter the first style and 
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the change will cascade through the child styles. Aside from controlling elements like font style, size 
and spacing, you can set the chapter style to always be on a new page (use the Keep options menu: 
“start paragraph” selection).

Another very useful trick is to set the distance from the top of the page the chapter title should fall. 
You do this by creating an invisible line at the top of the page. Go to the Paragaph rules menu. Turn 
on “Rule above”, change the rule colour to none, turn on “Keep in frame”, and set an offset distance. If 
the Chapter title style is the first on a page, it will “draw” the invisible line and shift the title down by 
the selected amount. I apply the same paragraph rule offset to all styles I want to line up.
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With the chapter title style set up carefully, when you import text downloaded from AO3, you can 
replace that chapter title style (heading 2, normally) with your Chapter title style using Find and Replace 
and all the chapters will automatically start on a new page (and you can set “Next odd page” if you like), 
and the title will be the correct distance down the page. If you want an actual line at the top of a new 
chapter page as a decoration, you can make the paragraph rule visible by giving it a colour and weight.

Create each style you think you will need, basing it on the logical parent style. When you have them 
set, import the text. 

Importing the text
To preserve AO3 styles, I download an HTML file, copy this to Google docs and download a Word file 
(rich text format preserves italics and suchlike, and chapter titles, but nothing extraneous). Place your 
cursor in the page and press control D (“Place”, under the File drop down), navigate to where the text 
is and before clicking Open, tick “Show import options”. In the dialog that opens, make sure “preserve 
formatting of text and tables” is ticked and  style options are set to : “rename incoming styles”, this way, 
your carefully named styles won’t be disrupted and incoming styles will get an rtf or wrd tag. Uncheck 
“preserve page breaks”. Then press ok and wait for the program to process the styles. When the cursor 
gains a picture of text (it’s called a “loaded cursor”), place the cursor in the top left corner of the page’s 
margin frame, and hold down shift while clicking. This will automatically create threaded pages to 
accommodate all the incoming text.

Style the text
In order to preserve the author’s italics, style italics first. To do this, you will have to have set up an 
Italic character style: to make a style that can be applied to any font, only set one element, under basic 
character formats, select Italic from the drop down list next to font style. Do not set a font.
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Before applying any document styles, go to find / change (control F) and change all text formatted 
Italic to your Italic character style. 

Under Find format, click the “T magnifier “button and ignoring the character style and paragraph style 
boxes, go to basic character style and again, under font style, select “italic” , click ok. In the “change 
format” box, select the Italic character style. Now you can “change all” and every instance of italics in 
the text will be styled with a proper Italic character style. When you then change the incoming “normal 
rtf ” style to the document’s normal style, all paragraphs styled “normal rtf ” will be changed, but the 
character style “italic” will be preserved.

So, next “Find format” normal rtf (remember to bin the previous search first) and “change format” to 
the document’s “normal” paragraph style, then the heading 1 style to the document’s main title style, the 
incoming “heading 2” style to your chapter style, remembering to bin the previous “find” and “change” 
format search terms each time. Make sure the search area is set to document or story, not selection.

In the Find/change panel you can run any number of queries on the text to make global changes. At the 
top, the Query drop down contains anumber of preset find/changes. One is double dash to emdash, 
which is often useful. The InDesign Find/change function is very powerful and you should use it as much 
as possible to hunt for things you need to change or check within the text. For instance, set a “break” 
style and then find the character or set of characters the author used for breaks and replace with the 
character you want to use, while also changing the format to your break style (with spacing built in).
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Working with parent pages
Many elements on a page are controlled by the parent page. By default, all pages in a document are 
styled as “A” pages, controlled by A-parent. There is also a default “None” parent page.

By editing the Parent, you can set things like automatic page numbers and headers/footers. To edit 
parent A, in the pages panel, double click A-Parent. This opens the parent page, any text or text area 
you set up on a parent page will be displayed on all pages that are designated as “A”, or “B” or any number 
of other parent pages you set up. Set up a parent to control any element that must be consistently 
applied to a number of pages. Elements on parent pages cannot be altered or deleted from normal 
pages controlled by that parent, in order to change anything, you have to edit the parent.

Normal pages will have a page number and a header or footer containing things like the book title, 
chapter title or author name (American books seem often to put the author name in the page header 
or footer, I don’t usually, because this does not seem to be a convention in books published in the UK, 
where SA imports books from, and whose conventions SA publishers appear to follow).

Page numbers
To apply page numbers, you need to create a paragraph style, and to draw text boxes on the A-parent 
pages (do it on both of the facing pages). Apply the page number style to these text boxes, then, under 
the main Type menu, go down to Insert special characters and select, under “Markers”, “current page 
number”. An A (for A-parent) will appear in the text frame intended for the page number. You can add 
other decorations here as well, like special glyphs or the like). Now go back to a page in the document, 
it will display the correct page number.

Page headers/footers
To set up page headers or footers that can automatically 
display changing information, such as the chapter title, 
under the Type menu, go to Text variables and select 
“define”. There are a number of presets you can use, but 
for books, it is better to write your own. In the menu 
that opens, select “New” and give the style a name, 
then (for the book title) select “Custom text” and type 
the book’s title into the panel. Hit Ok.

To make a variable for the chapter titles, select “New” 
again, name the style and this time, select running 
header (paragraph style) from the Type drop down. 
select “chapter title” as the style for the running header. 
When you have created your text variables for headers/
footers, hit “done”.

Now you can apply these variables to the header/footer 
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text frames. Draw the frames on the parent page (if you are using headers, now is the time you create a 
new parent for chapter opening pages: in the Pages hamburger menu, choose “new parent” and make 
sure the new parent is based on “none”. Now you make a parent page with only footers. 

On the main A-parent, draw text frames for the headers, give them your “header” style and with the 
Type tool selected, go to “text variable” > insert variable and from the list, choose the variable you want 
(one of those you just made). So, on the left hand page, insert the “Book title” variable that you typed 
custom text for. The custom text you typed will appear on the parent page. To insert the chapter title 
header, which will change through the book, insert the “chapter title” running header you created. The  
words <chapter title> will appear on the parent page, because this variable takes its text from the style 
you specified. Thus, in a book, any text styled as chapter title will be inserted into that header, until a 
new piece of text with that style occurs, when the new relevant text will be inserted, and so on through 
the book.

Any page that you want neither headers nor footers to appear on, can have the “none” parent applied. 
You can also put a picture that will appear on a number of pages (like a picture above the chapter title) 
on the relevant parent page. Any element that must occur on either a left or right page, pust be applied 
to both of the facing parent pages, because left hand pages take their styles from the left hand parent 
and the right from the right.

To apply a parent other than A-parent to pages in your document, you need to work in the pages panel. 
Scroll through the document, and when you reach a chapter opening page that needs the special “chap” 
or B or whatever it is called (the prefix is limited to 4 characters) parent, double click. The page will be 
highlighted in the pages panel. Now you can drag the Parent style onto that page. To apply the same 
style to a group of consecutive pages, use the “apply style” option in the pages menu.

Creating a table of contents
When you have the book set up how you want it, and are unlikely to make more changes that affect 
page numbering, you can create a Table of Contents. Under the Layout menu, go to Table of Contents.

Contents
Setting up the workspace 1

Setting up a new document 4

Setting text styles 5

Importing the text 8
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Style the text 8

Working with parent pages 10

Page numbers 10

Page headers/footers 10

Creating a table of contents 11

When you have set up the parameters (as shown below) you get a “loaded cursor” that you can place 
on a blank page (I pasted it above) you have inserted into the document at the correct place (insert 

these blanks before creating the Contents). If your menu does not have all these fields, click “More 
options”. Look through the styles under “styles in Table of Contents” and select the main style to include 
(Chapter title, normally) and click “Add”. Now apply the style (how you want the listings to appear) 
— by default it will be same style, but if you don’t change it, every listing will be styled “Chapter title”, 
so choose another, probably Normal no indent. Choose a character style to apply to the page number 
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from the list or create one especially, in the example above I chose bold italics. Under “Between entry 
and number” highlight the code in the box and change it to “right indent” from the drop down. Under 
“Options” make sure “remove forced line break” is ticked, thus, if you have broken a chapter title to be 
more elegant on the page, that forced break will not disrupt your Table of Contents. It is also worth 
noting, that it is a good habit to write special styles for elements in the front matter (book title, half 
title, author name etc) and not just alter the chapter title style, because anything styled with even an 
altered version of the specified style to include in Contents, will be included and would then have to 
be erased. Set a style for the heading, and type it how you want it to appear (the default is Contents, 
which I prefer to “Table of Contents”, but you may want the heading on the list to be something else).

If something later changes (the page numbering shifts or something), you can go back to Layout and 
select “Update Table of Contents”. If it is greyed out, erase the current ToC and create it from scratch.

In order to place dots (leaders) between the listing and the number, highlight the text and go to tabs 
under the Type menu and set it there.

Pictures and graphics
If you place pictures in your text, it is a good idea to anchor them with the text you want them to remain 
with, thus if something else shifts, the picture remains with the text it relates to, and moves along with 
that text. The anchors work the same way as they do in Word. You can drag the anchor into a paragraph 
of text, or anchor it to a blank paragraph mark. You can then set the text wrap. Annoyingly (it’s one 
of the baffling stupid things about ID that never gets fixed), if the anchor is above the picture, the text 
above where the anchor is, will not be affected by the text wrap, in other words, some text could get 
hidden by the picture. If the picture is full width of the page, or centred and text does not need to “run 
around” it, set the text wrap to “jump object”.

Other stuff
At the bottom of the ID window is a green or red dot. The green one will be labelled “no errors”. 
The red one indicates problems: overset text, or missing fonts, typically. If you have a red dot, check 
the problem in the “preflight” panel (Window> Output > Preflight) It will show you where you have 
overset text. Sometimes, there is just a paragraph mark that causes ID to think there is following text. 
If your text becomes too long for the pages of the document (after you insert chapters starting on their 
own pages this can happen, but usually, the text that comes in from AO3 takes up more space, because 
the papragraphs are styled with space after, and book paragraphs typically are not) the final page will 
have a red plus in a box at the bottom right. In order to create new pages for the overset text to occupy, 
in the Pages panel, highlight the last page and click the plus, this makes one extra page. Now, using the 
object tool, click the red plus, you will get a loaded cursor, place it at the top left corner of the text frame 
on the new page, hold shift and click, this will make enough pages to accommodate the overset text.

If you have too many pages, highlight them in the Pages panel and drag them to the bin. You will 
get a dialog that asks if you want to delete them, because they contain text (the stuff controlled by the 
parent page), you can click OK.

If there are missing fonts, you can go to “find / replace fonts” under the Type menu and search for the 
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missing ones. Sometimes, a style includes a font style the font doesn’t have (eg semibold). This can 
happen if you changed a font and forgot to make all the cascading changes. Sometimes, ID may have 
decided a font is inactive and you need to download it from Creative Cloud again. In the text itself, a 
missing font style will be indicated with a pale pink highlight (eg, some title fonts don’t have italics, 
and you have styled something italic).

If you want to see different parts of the document at the same time, you can turn on split screen. 
It is the “open book” logo at the bottom right of the pane where the book is displayed. To return to one 
pane, click that button again.

To export  a PDF you can use to impose the book for printing, under File, choose export. Don’t try 
to print booklets from ID, it is truly shit at imposition. If you wanted to send a client a proof  that they 
could see displayed in spreads, click “Spreads” under “export as”. You don’t have to make anyother 
choices in Export.
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If you suddenly have no text! it could be that there is a word that is too big for the page in the style 
assigned to it (maybe the title is set at 72pt and one of the words is too long, and you have set it to no 
hyphenation. ID can’t display that, or anything after it.  Don’t panic (ask me how I know this) Under 
Edit, go to Edit in Story Editor. The text will open in a word processor, and here you can see what is 
overset (it has a red vertical line in the margin). You can then edit the style until that long word can fit. 

If all the text is suddenly italic or another character style, make sure you don’t have that character 
style  selected by accident (it happens quite often to me). Make sure the None style is selected unless 
you specifically want to apply another character style.

That’s all, folks!
I think that’s it, but feel free to ask about anything I have left out that you notice. This is just the way I 
have developed to lay out books quickly and consistently in InDesign. All Adobe products have many 
ways of working, and you may find other ways that suit you better..




